Search

Categories

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Send mail to the author(s) E-mail

# Wednesday, 18 January 2012
( n2 )

Prepare_AllDependencies.bat

checks for .NET4 then runs build..

image

hmm.. possibly a problem with an early version of .NET4.5?

image

also on their wiki is broken.. hmmm

trying to uninstall the CTP

image

cool the build now worked.

Introduction:

N2 first published in 2006.. since then 45 versions have been released with the latest being 2.2 in June 2011.

couldn’t get MVC one to run.. suspect it needs MVC2 and I have 3.

Web Platform Installer has it but version 2.1.

image

can also do webmatrix

Dinamico is the MVC3 one:

image

or templates:

image

Can also get it via NuGet (Dianamico too)…gets Castle Core, NHibernate, Lucene, Castle.Windsor, DotNetZip, SQLLite

image

got this:

image

latest version of log4net i 1.2.11

hmmm..grabbed it from here: http://archive.apache.org/dist/incubator/log4net/1.2.10/  and put the dll in refs.

Then got to installer screen:

image

then admin screen

image

first impressions.. not that slick..looks old…and not many people seem to use it.

videos:

http://training.lithe.net.au/basics/introduction-to-n2

| | #